Apache Superset: Sensitive Data Exposure via REST API (disabled by default)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag. When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | 0.0.0 to before 6.0.0 | 6.0.0 | Patch available | CNA |
| — | apache-superset (PyPI) | before 6.0.0 | 6.0.0 | Patch available | GHSA-h294-8fxm-m2pj |
- Apache Superset VendorApache Affected 0.0.0 to before 6.0.0 Fixed in 6.0.0 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 6.0.0 Fixed in 6.0.0 Patch available GHSA-h294-8fxm-m2pj
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 6.0.0
- Fix · GHSA-h294-8fxm-m2pj apache-superset (PyPI) Fixed in 6.0.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 6.0.0
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2026-19324 Apache Superset: Improper Authorization in Dataset Creation Allows Access Control BypassPriority LOW 32
- TI-2026-19326 Apache Superset: SQLLab Read-Only Bypass on PostgreSQLPriority LOW 31
- TI-2026-19322 Apache Superset: Improper Neutralization of Special Elements used in a SQL CommandPriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23983
- 2026-10-03 Alias added: GHSA-h294-8fxm-m2pj
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-23983 · CVE Program
- CVE-2026-23983 · NVD
- FIRST EPSS
- GHSA-h294-8fxm-m2pj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences