LibreNMS affected by reflected XSS via email field
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are vulnerable to Reflected XSS attacks via email field. This issue has been fixed in version 26.2.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00336 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 26.2.0librenms/librenms (Packagist): 26.2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 26.2.0 | 26.2.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 26.2.0 | 26.2.0 | Patch available | GHSA-gqx7-99jw-6fpr |
- librenms Vendorlibrenms Affected before 26.2.0 Fixed in 26.2.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 26.2.0 Fixed in 26.2.0 Patch available GHSA-gqx7-99jw-6fpr
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.2.0
- Fix · GHSA-gqx7-99jw-6fpr librenms/librenms (Packagist) Fixed in 26.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26987
- 2026-10-03 Alias added: GHSA-gqx7-99jw-6fpr
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-26987 · CVE Program
- CVE-2026-26987 · NVD
- FIRST EPSS
- GHSA-gqx7-99jw-6fpr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences