LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below contain an SQL Injection vulnerability in the ajax_table.php endpoint. The application fails to properly sanitize or parameterize user input when processing IPv6 address searches. Specifically, the address parameter is split into an address and a prefix, and the prefix portion is directly concatenated into the SQL query string without validation. This allows an attacker to inject arbitrary SQL commands, potentially leading to unauthorized data access or database manipulation. This issue has been fixed in version 26.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 26.2.0 | 26.2.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 26.2.0 | 26.2.0 | Patch available | GHSA-h3rv-q4rq-pqcv |
- librenms Vendorlibrenms Affected before 26.2.0 Fixed in 26.2.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 26.2.0 Fixed in 26.2.0 Patch available GHSA-h3rv-q4rq-pqcv
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.2.0
- Fix · GHSA-h3rv-q4rq-pqcv librenms/librenms (Packagist) Fixed in 26.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26988
- 2026-10-03 Alias added: GHSA-h3rv-q4rq-pqcv
- 2026-10-25 EPSS moved to the 90th–95th percentile
- 2026-11-03 EPSS moved to the 95th–99th percentile
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-26988 · CVE Program
- CVE-2026-26988 · NVD
- FIRST EPSS
- GHSA-h3rv-q4rq-pqcv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences