LibreNMS has Time-Based Blind SQL Injection in address-search.inc.php
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below have a Time-Based Blind SQL Injection vulnerability in address-search.inc.php via the address parameter. When a crafted subnet prefix is supplied, the prefix value is concatenated directly into an SQL query without proper parameter binding, allowing an attacker to manipulate query logic and infer database information through time-based conditional responses. This vulnerability requires authentication and is exploitable by any authenticated user. This issue has been fixedd in version 26.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 26.2.0 | 26.2.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 26.2.0 | 26.2.0 | Patch available | GHSA-79q9-wc6p-cf92 |
- librenms Vendorlibrenms Affected before 26.2.0 Fixed in 26.2.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 26.2.0 Fixed in 26.2.0 Patch available GHSA-79q9-wc6p-cf92
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.2.0
- Fix · GHSA-79q9-wc6p-cf92 librenms/librenms (Packagist) Fixed in 26.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26990
- 2026-10-03 Alias added: GHSA-79q9-wc6p-cf92
- 2026-10-18 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the 90th–95th percentile
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-26990 · CVE Program
- CVE-2026-26990 · NVD
- FIRST EPSS
- GHSA-79q9-wc6p-cf92 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences