Read the docs
TI-2026-21470 Aliases CVE-2026-26991GHSA-5pqf-54qp-32wx

LibreNMS vulnerable to Stored Cross-site Scripting through unsanitized /device-groups name

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. In versions 26.1.1 and below, the device group name is not sanitized, allowing attackers with admin privileges to perform Stored Cross-Site Scripting (XSS) attacks. When a user adds a device group, an HTTP POST request is sent to the Request-URI "/device-groups". The name of the newly created device group is stored in the value of the name parameter. After the device group is created, the entry is displayed along with relevant buttons such as Rediscover Devices, Edit, and Delete. This issue has been fixed in version 26.2.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0025 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed librenms (librenms): 26.2.0librenms/librenms (Packagist): 26.2.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
librenmslibrenmsbefore 26.2.026.2.0Patch availableCNA
—librenms/librenms (Packagist)before 26.2.026.2.0Patch availableGHSA-5pqf-54qp-32wx
  • librenms Vendorlibrenms Affected before 26.2.0 Fixed in 26.2.0 Patch available CNA
  • librenms/librenms (Packagist) Vendor— Affected before 26.2.0 Fixed in 26.2.0 Patch available GHSA-5pqf-54qp-32wx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*before 26.2.0Vulnerablelibrenms
  • cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* Versions before 26.2.0 Vulnerable ·librenms

Remediation

  • Fix · CNA librenms (librenms) Fixed in 26.2.0
  • Fix · GHSA-5pqf-54qp-32wx librenms/librenms (Packagist) Fixed in 26.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-26991
  2. 2026-10-03 Alias added: GHSA-5pqf-54qp-32wx

References

  • TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
  • TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
  • TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
  • TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
  • TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
  • TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
See all 105 →

Sources