fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fluent | fluent-plugin-s3 | 0.7.0 to before 1.8.5 | 1.8.5 | Patch available | CNA |
| — | fluent-plugin-s3 (RubyGems) | 0.7.0 to before 1.8.5 | 1.8.5 | Patch available | GHSA-xv9w-7v6q-hpjh |
- fluent-plugin-s3 Vendorfluent Affected 0.7.0 to before 1.8.5 Fixed in 1.8.5 Patch available CNA
- fluent-plugin-s3 (RubyGems) Vendor— Affected 0.7.0 to before 1.8.5 Fixed in 1.8.5 Patch available GHSA-xv9w-7v6q-hpjh
Remediation
- Fix · CNA fluent-plugin-s3 (fluent) Fixed in 1.8.5
- Fix · GHSA-xv9w-7v6q-hpjh fluent-plugin-s3 (RubyGems) Fixed in 1.8.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44162
- 2026-10-03 Alias added: GHSA-xv9w-7v6q-hpjh
References
More fluent vulnerabilities
- TI-2026-44158 Fluent Bit: Remote stack buffer overflow in Fluent Bit `out_forward` Secure-Forward `PONG` handler CVSS 4.0CRITICAL 9.2
- TI-2022-18753 Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration) CVSS 3.1CRITICAL 9.8
- TI-2026-32064 Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder CVSS 3.1CRITICAL 9.8
- TI-2017-07995 Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may… CVSS 3.0CRITICAL 9.8
- TI-2020-14076 An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated… CVSS 3.1HIGH 8.8
- TI-2026-32142 Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` CVSS 3.1HIGH 7.5
Sources
- CVE-2026-44162 · CVE Program
- CVE-2026-44162 · NVD
- FIRST EPSS
- GHSA-xv9w-7v6q-hpjh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences