Read the docs
TI-2026-32064 Aliases CVE-2026-44024GHSA-44hj-4m45-frj3

Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder

Priority MEDIUM 51CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd allows dynamically constructing file paths using the ${tag} placeholder, and insufficient validation of ${tag} in file configurations such as the path parameter of the out_file plugin allows attackers sending untrusted tags containing path traversal characters to write or overwrite arbitrary files and potentially achieve remote code execution. This issue is fixed in version 1.19.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01085 65th percentileScored 2026-11-07
Fix Fixed fluentd (fluent): 1.19.3fluentd (RubyGems): 1.19.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
fluentfluentdbefore 1.19.31.19.3Patch availableCNA
—fluentd (RubyGems)before 1.19.31.19.3Patch availableGHSA-44hj-4m45-frj3
  • fluentd Vendorfluent Affected before 1.19.3 Fixed in 1.19.3 Patch available CNA
  • fluentd (RubyGems) Vendor— Affected before 1.19.3 Fixed in 1.19.3 Patch available GHSA-44hj-4m45-frj3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:*before 1.19.3Vulnerablefluent
  • cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:* Versions before 1.19.3 Vulnerable ·fluent

Remediation

  • Fix · CNA fluentd (fluent) Fixed in 1.19.3
  • Fix · GHSA-44hj-4m45-frj3 fluentd (RubyGems) Fixed in 1.19.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-44024
  2. 2026-10-03 Alias added: GHSA-44hj-4m45-frj3

References

  • TI-2022-18753 Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration) CVSS 3.1CRITICAL 9.8
  • TI-2017-07995 Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may… CVSS 3.0CRITICAL 9.8
  • TI-2020-14076 An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated… CVSS 3.1HIGH 8.8
  • TI-2026-32142 Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` CVSS 3.1HIGH 7.5
  • TI-2026-32065 Fluentd: Exposure of Sensitive Information via Monitor Agent API CVSS 3.1HIGH 7.5
  • TI-2026-32143 Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` CVSS 3.1HIGH 7.2
See all 7 →

Sources