Read the docs
TI-2026-32142 Aliases CVE-2026-44160GHSA-j9cw-hwqf-85w7

Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`

Priority MEDIUM 40CWE-409Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0062 49th percentileScored 2026-11-07
Fix Fixed fluentd (fluent): 1.19.3fluentd (RubyGems): 1.19.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
fluentfluentdbefore 1.19.31.19.3Patch availableCNA
—fluentd (RubyGems)before 1.19.31.19.3Patch availableGHSA-j9cw-hwqf-85w7
  • fluentd Vendorfluent Affected before 1.19.3 Fixed in 1.19.3 Patch available CNA
  • fluentd (RubyGems) Vendor— Affected before 1.19.3 Fixed in 1.19.3 Patch available GHSA-j9cw-hwqf-85w7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:*before 1.19.3Vulnerablefluent
  • cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:* Versions before 1.19.3 Vulnerable ·fluent

Remediation

  • Fix · CNA fluentd (fluent) Fixed in 1.19.3
  • Fix · GHSA-j9cw-hwqf-85w7 fluentd (RubyGems) Fixed in 1.19.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-44160
  2. 2026-10-03 Alias added: GHSA-j9cw-hwqf-85w7

References

  • TI-2022-18753 Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration) CVSS 3.1CRITICAL 9.8
  • TI-2026-32064 Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder CVSS 3.1CRITICAL 9.8
  • TI-2017-07995 Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may… CVSS 3.0CRITICAL 9.8
  • TI-2020-14076 An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated… CVSS 3.1HIGH 8.8
  • TI-2026-32065 Fluentd: Exposure of Sensitive Information via Monitor Agent API CVSS 3.1HIGH 7.5
  • TI-2026-32143 Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` CVSS 3.1HIGH 7.2
See all 7 →

Sources