Read the docs
TI-2022-18753 Aliases CVE-2022-39379GHSA-fppq-mj76-fpj2

Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

Priority HIGH 71CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.

Summary

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.44983 98th percentileScored 2026-11-07
Fix Partial fluentd (fluent): 1.15.3fluentd (RubyGems): 1.15.3Red Hat: 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
fluentfluentd1.13.2 to before 1.15.31.15.3Patch availableCNA
—fluentd (RubyGems)1.13.2 to before 1.15.31.15.3Patch availableGHSA-fppq-mj76-fpj2
  • fluentd Vendorfluent Affected 1.13.2 to before 1.15.3 Fixed in 1.15.3 Patch available CNA
  • fluentd (RubyGems) Vendor— Affected 1.13.2 to before 1.15.3 Fixed in 1.15.3 Patch available GHSA-fppq-mj76-fpj2

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:*1.13.2 to before 1.15.3Vulnerablefluent
cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*37VulnerableFedoraproject
  • cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:* Versions 1.13.2 to before 1.15.3 Vulnerable ·fluent
  • cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject

Remediation

  • Fix · CNA fluentd (fluent) Fixed in 1.15.3
  • Fix · GHSA-fppq-mj76-fpj2 fluentd (RubyGems) Fixed in 1.15.3 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11AffectedNo fix planned: Out of support scope
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Out of support scope
Not affected: 1 product
  • Logging Subsystem for Red Hat OpenShift

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-39379
  2. 2026-10-03 Alias added: GHSA-fppq-mj76-fpj2

References

  • TI-2026-32064 Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder CVSS 3.1CRITICAL 9.8
  • TI-2017-07995 Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may… CVSS 3.0CRITICAL 9.8
  • TI-2020-14076 An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated… CVSS 3.1HIGH 8.8
  • TI-2026-32142 Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` CVSS 3.1HIGH 7.5
  • TI-2026-32065 Fluentd: Exposure of Sensitive Information via Monitor Agent API CVSS 3.1HIGH 7.5
  • TI-2026-32143 Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` CVSS 3.1HIGH 7.2
See all 7 →

Sources