Read the docs
TI-2026-35256 Aliases CVE-2026-47759GHSA-q742-qvgc-gc2f

TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

Priority LOW 39CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00281 20th percentileScored 2026-11-07
Fix Fixed tinymce (tinymce): 5.11.1, 7.9.3, 8.5.1tinymce (npm): 7.9.3, 8.5.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
tinymcetinymcebefore 5.11.1; 6.0.0 – 6.8.6; 7.0.0 to before 7.9.3; 8.0.0 to before 8.5.15.11.1, 7.9.3, 8.5.1Patch availableCNA
—tinymce (npm)up to 5.10.9—No fix listedGHSA-q742-qvgc-gc2f
—tinymce (npm)6.0.0 to before 7.9.37.9.3Patch availableGHSA-q742-qvgc-gc2f
—tinymce (npm)8.0.0 to before 8.5.18.5.1Patch availableGHSA-q742-qvgc-gc2f
—TinyMCE (NuGet)up to 5.10.9—No fix listedGHSA-q742-qvgc-gc2f
—TinyMCE (NuGet)6.0.0 to before 7.9.37.9.3Patch availableGHSA-q742-qvgc-gc2f
—TinyMCE (NuGet)8.0.0 to before 8.5.18.5.1Patch availableGHSA-q742-qvgc-gc2f
—tinymce/tinymce (Packagist)up to 5.10.9—No fix listedGHSA-q742-qvgc-gc2f
—tinymce/tinymce (Packagist)6.0.0 to before 7.9.37.9.3Patch availableGHSA-q742-qvgc-gc2f
—tinymce/tinymce (Packagist)8.0.0 to before 8.5.18.5.1Patch availableGHSA-q742-qvgc-gc2f
  • tinymce Vendortinymce Affected before 5.11.1; 6.0.0 – 6.8.6; 7.0.0 to before 7.9.3; 8.0.0 to before 8.5.1 Fixed in 5.11.1, 7.9.3, 8.5.1 Patch available CNA
  • tinymce (npm) Vendor— Affected up to 5.10.9 Fixed in — No fix listed GHSA-q742-qvgc-gc2f
  • tinymce (npm) Vendor— Affected 6.0.0 to before 7.9.3 Fixed in 7.9.3 Patch available GHSA-q742-qvgc-gc2f
  • tinymce (npm) Vendor— Affected 8.0.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-q742-qvgc-gc2f
  • TinyMCE (NuGet) Vendor— Affected up to 5.10.9 Fixed in — No fix listed GHSA-q742-qvgc-gc2f
  • TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 7.9.3 Fixed in 7.9.3 Patch available GHSA-q742-qvgc-gc2f
  • TinyMCE (NuGet) Vendor— Affected 8.0.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-q742-qvgc-gc2f
  • tinymce/tinymce (Packagist) Vendor— Affected up to 5.10.9 Fixed in — No fix listed GHSA-q742-qvgc-gc2f
  • tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 7.9.3 Fixed in 7.9.3 Patch available GHSA-q742-qvgc-gc2f
  • tinymce/tinymce (Packagist) Vendor— Affected 8.0.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-q742-qvgc-gc2f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*before 5.11.1; 6.0.0 to before 7.9.3; 8.0.0 to before 8.5.1VulnerableTiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions before 5.11.1; 6.0.0 to before 7.9.3; 8.0.0 to before 8.5.1 Vulnerable ·Tiny

Remediation

  • Fix · CNA tinymce (tinymce) Fixed in 5.11.1, 7.9.3, 8.5.1
  • Fix · GHSA-q742-qvgc-gc2f tinymce (npm) Fixed in 7.9.3 Advisory →
  • Fix · GHSA-q742-qvgc-gc2f tinymce (npm) Fixed in 8.5.1 Advisory →
  • Fix · GHSA-q742-qvgc-gc2f TinyMCE (NuGet) Fixed in 7.9.3 Advisory →
  • Fix · GHSA-q742-qvgc-gc2f TinyMCE (NuGet) Fixed in 8.5.1 Advisory →
  • Fix · GHSA-q742-qvgc-gc2f tinymce/tinymce (Packagist) Fixed in 7.9.3 Advisory →
  • Fix · GHSA-q742-qvgc-gc2f tinymce/tinymce (Packagist) Fixed in 8.5.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-47759
  2. 2026-10-03 Alias added: GHSA-q742-qvgc-gc2f
  3. 2026-10-16 Priority changed: MEDIUM → LOW

References

  • TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
  • TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
  • TI-2014-03123 Cross-site request forgery (CSRF) vulnerability in the TinyMCE Color Picker plugin before… CVSS 2.0MEDIUM 6.8
See all 20 →

Sources