Read the docs
TI-2026-35257 Aliases CVE-2026-47760GHSA-mh5m-5hw4-5c69

TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs

Priority LOW 37CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00191 8th percentileScored 2026-11-07
Fix Fixed tinymce (tinymce): 7.1.0tinymce (npm): 7.1.0+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
tinymcetinymce6.0.0 to before 7.1.07.1.0Patch availableCNA
—tinymce (npm)6.8.0 to before 7.1.07.1.0Patch availableGHSA-mh5m-5hw4-5c69
—TinyMCE (NuGet)6.8.0 to before 7.1.07.1.0Patch availableGHSA-mh5m-5hw4-5c69
—tinymce/tinymce (Packagist)6.8.0 to before 7.1.07.1.0Patch availableGHSA-mh5m-5hw4-5c69
  • tinymce Vendortinymce Affected 6.0.0 to before 7.1.0 Fixed in 7.1.0 Patch available CNA
  • tinymce (npm) Vendor— Affected 6.8.0 to before 7.1.0 Fixed in 7.1.0 Patch available GHSA-mh5m-5hw4-5c69
  • TinyMCE (NuGet) Vendor— Affected 6.8.0 to before 7.1.0 Fixed in 7.1.0 Patch available GHSA-mh5m-5hw4-5c69
  • tinymce/tinymce (Packagist) Vendor— Affected 6.8.0 to before 7.1.0 Fixed in 7.1.0 Patch available GHSA-mh5m-5hw4-5c69

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*6.8.0 to before 7.1.0VulnerableTiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions 6.8.0 to before 7.1.0 Vulnerable ·Tiny

Remediation

  • Fix · CNA tinymce (tinymce) Fixed in 7.1.0
  • Fix · GHSA-mh5m-5hw4-5c69 tinymce (npm) Fixed in 7.1.0 Advisory →
  • Fix · GHSA-mh5m-5hw4-5c69 TinyMCE (NuGet) Fixed in 7.1.0 Advisory →
  • Fix · GHSA-mh5m-5hw4-5c69 tinymce/tinymce (Packagist) Fixed in 7.1.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-47760
  2. 2026-10-03 Alias added: GHSA-mh5m-5hw4-5c69

References

  • TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
  • TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
  • TI-2014-03123 Cross-site request forgery (CSRF) vulnerability in the TinyMCE Color Picker plugin before… CVSS 2.0MEDIUM 6.8
See all 20 →

Sources