Cross-site scripting in TinyMCE media plugin via data-mce-object
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The media plugin in TinyMCE, an open source rich text editor, is affected from 7.9.3 before 7.9.4 and from 8.5.1 before 8.9.3. It creates elements crafted through data-mce-object in the active document before sanitization. Those elements can run malicious scripts, causing stored cross-site scripting (CWE-79) for users with the media plugin enabled. An attacker with low privileges can exploit this, and user interaction is required.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tinymce | tinymce | 8.5.1 to before 8.9.3; 7.9.3 to before 7.9.4 | 8.9.3, 7.9.4 | Patch available | CNA |
| — | tinymce (npm) | 8.5.1 to before 8.9.3 | 8.9.3 | Patch available | GHSA-mf2p-h6hf-fcwm |
| — | TinyMCE (NuGet) | 8.5.1 to before 8.9.3 | 8.9.3 | Patch available | GHSA-mf2p-h6hf-fcwm |
| — | tinymce/tinymce (Packagist) | 8.5.1 to before 8.9.3 | 8.9.3 | Patch available | GHSA-mf2p-h6hf-fcwm |
| — | tinymce (npm) | 7.9.3 to before 7.9.4 | 7.9.4 | Patch available | GHSA-mf2p-h6hf-fcwm |
| — | TinyMCE (NuGet) | 7.9.3 to before 7.9.4 | 7.9.4 | Patch available | GHSA-mf2p-h6hf-fcwm |
| — | tinymce/tinymce (Packagist) | 7.9.3 to before 7.9.4 | 7.9.4 | Patch available | GHSA-mf2p-h6hf-fcwm |
- tinymce Vendortinymce Affected 8.5.1 to before 8.9.3; 7.9.3 to before 7.9.4 Fixed in 8.9.3, 7.9.4 Patch available CNA
- tinymce (npm) Vendor— Affected 8.5.1 to before 8.9.3 Fixed in 8.9.3 Patch available GHSA-mf2p-h6hf-fcwm
- TinyMCE (NuGet) Vendor— Affected 8.5.1 to before 8.9.3 Fixed in 8.9.3 Patch available GHSA-mf2p-h6hf-fcwm
- tinymce/tinymce (Packagist) Vendor— Affected 8.5.1 to before 8.9.3 Fixed in 8.9.3 Patch available GHSA-mf2p-h6hf-fcwm
- tinymce (npm) Vendor— Affected 7.9.3 to before 7.9.4 Fixed in 7.9.4 Patch available GHSA-mf2p-h6hf-fcwm
- TinyMCE (NuGet) Vendor— Affected 7.9.3 to before 7.9.4 Fixed in 7.9.4 Patch available GHSA-mf2p-h6hf-fcwm
- tinymce/tinymce (Packagist) Vendor— Affected 7.9.3 to before 7.9.4 Fixed in 7.9.4 Patch available GHSA-mf2p-h6hf-fcwm
Remediation
Upgrade the tinymce package to 8.9.3 for the 8.x line or 7.9.4 for the 7.x line. For npm, NuGet and Packagist, use tinymce 8.9.3 or 7.9.4 for the same lines.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA tinymce (tinymce) Fixed in 8.9.3, 7.9.4
- Fix · GHSA-mf2p-h6hf-fcwm tinymce (npm) Fixed in 8.9.3 Advisory →
- Fix · GHSA-mf2p-h6hf-fcwm TinyMCE (NuGet) Fixed in 8.9.3 Advisory →
- Fix · GHSA-mf2p-h6hf-fcwm tinymce/tinymce (Packagist) Fixed in 8.9.3 Advisory →
- Fix · GHSA-mf2p-h6hf-fcwm tinymce (npm) Fixed in 7.9.4 Advisory →
- Fix · GHSA-mf2p-h6hf-fcwm TinyMCE (NuGet) Fixed in 7.9.4 Advisory →
- Fix · GHSA-mf2p-h6hf-fcwm tinymce/tinymce (Packagist) Fixed in 7.9.4 Advisory →
Vendor assessments
Timeline
- 2026-10-27 Threatist record created from CVE-2026-116675
- 2026-10-27 Alias added: GHSA-mf2p-h6hf-fcwm
- 2026-10-28 CISA SSVC decision points changed
- 2026-10-28 Priority changed: MEDIUM → LOW
- 2026-11-06 Affected versions changed · Red Hat
- 2026-11-06 CVSS score added · Red Hat
References
Other 6
- https://github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm
- https://github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2
- https://github.com/tinymce/tinymce/releases/tag/8.9.3
- https://www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview
- https://github.com/tinymce/tinymce
More tinymce vulnerabilities
- TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
- TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
- TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
- TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
- TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
- TI-2014-03123 Cross-site request forgery (CSRF) vulnerability in the TinyMCE Color Picker plugin before… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2026-116675 · CVE Program
- CVE-2026-116675 · NVD
- FIRST EPSS
- GHSA-mf2p-h6hf-fcwm · GitHub Advisory Database · CC BY 4.0
- CVE-2026-116675 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences