TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tinymce | tinymce | before 5.11.1; 6.0.0 – 6.8.6; 7.0.0 to before 7.9.3; 8.0.0 to before 8.5.1 | 5.11.1, 7.9.3, 8.5.1 | Patch available | CNA |
| — | tinymce (npm) | up to 5.10.9 | — | No fix listed | GHSA-vg35-5wq7-3x7w |
| — | tinymce (npm) | 6.0.0 to before 7.9.3 | 7.9.3 | Patch available | GHSA-vg35-5wq7-3x7w |
| — | tinymce (npm) | 8.0.0 to before 8.5.1 | 8.5.1 | Patch available | GHSA-vg35-5wq7-3x7w |
| — | TinyMCE (NuGet) | up to 5.10.9 | — | No fix listed | GHSA-vg35-5wq7-3x7w |
| — | TinyMCE (NuGet) | 6.0.0 to before 7.9.3 | 7.9.3 | Patch available | GHSA-vg35-5wq7-3x7w |
| — | TinyMCE (NuGet) | 8.0.0 to before 8.5.1 | 8.5.1 | Patch available | GHSA-vg35-5wq7-3x7w |
| — | tinymce/tinymce (Packagist) | up to 5.10.9 | — | No fix listed | GHSA-vg35-5wq7-3x7w |
| — | tinymce/tinymce (Packagist) | 6.0.0 to before 7.9.3 | 7.9.3 | Patch available | GHSA-vg35-5wq7-3x7w |
| — | tinymce/tinymce (Packagist) | 8.0.0 to before 8.5.1 | 8.5.1 | Patch available | GHSA-vg35-5wq7-3x7w |
- tinymce Vendortinymce Affected before 5.11.1; 6.0.0 – 6.8.6; 7.0.0 to before 7.9.3; 8.0.0 to before 8.5.1 Fixed in 5.11.1, 7.9.3, 8.5.1 Patch available CNA
- tinymce (npm) Vendor— Affected up to 5.10.9 Fixed in — No fix listed GHSA-vg35-5wq7-3x7w
- tinymce (npm) Vendor— Affected 6.0.0 to before 7.9.3 Fixed in 7.9.3 Patch available GHSA-vg35-5wq7-3x7w
- tinymce (npm) Vendor— Affected 8.0.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-vg35-5wq7-3x7w
- TinyMCE (NuGet) Vendor— Affected up to 5.10.9 Fixed in — No fix listed GHSA-vg35-5wq7-3x7w
- TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 7.9.3 Fixed in 7.9.3 Patch available GHSA-vg35-5wq7-3x7w
- TinyMCE (NuGet) Vendor— Affected 8.0.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-vg35-5wq7-3x7w
- tinymce/tinymce (Packagist) Vendor— Affected up to 5.10.9 Fixed in — No fix listed GHSA-vg35-5wq7-3x7w
- tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 7.9.3 Fixed in 7.9.3 Patch available GHSA-vg35-5wq7-3x7w
- tinymce/tinymce (Packagist) Vendor— Affected 8.0.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-vg35-5wq7-3x7w
Remediation
- Fix · CNA tinymce (tinymce) Fixed in 5.11.1, 7.9.3, 8.5.1
- Fix · GHSA-vg35-5wq7-3x7w tinymce (npm) Fixed in 7.9.3 Advisory →
- Fix · GHSA-vg35-5wq7-3x7w tinymce (npm) Fixed in 8.5.1 Advisory →
- Fix · GHSA-vg35-5wq7-3x7w TinyMCE (NuGet) Fixed in 7.9.3 Advisory →
- Fix · GHSA-vg35-5wq7-3x7w TinyMCE (NuGet) Fixed in 8.5.1 Advisory →
- Fix · GHSA-vg35-5wq7-3x7w tinymce/tinymce (Packagist) Fixed in 7.9.3 Advisory →
- Fix · GHSA-vg35-5wq7-3x7w tinymce/tinymce (Packagist) Fixed in 8.5.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-47761
- 2026-10-03 Alias added: GHSA-vg35-5wq7-3x7w
- 2026-10-16 Priority changed: MEDIUM → LOW
References
More tinymce vulnerabilities
- TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
- TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
- TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
- TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
- TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
- TI-2014-03123 Cross-site request forgery (CSRF) vulnerability in the TinyMCE Color Picker plugin before… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2026-47761 · CVE Program
- CVE-2026-47761 · NVD
- FIRST EPSS
- GHSA-vg35-5wq7-3x7w · GitHub Advisory Database · CC BY 4.0
- CVE-2026-47761 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences