Read the docs
TI-2026-35503 Aliases CVE-2026-48062GHSA-2gr4-ppc7-7mhx

CodeIgniter: Uploaded file extension validation bypass in `ext_in` rule

Priority MEDIUM 50CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434.

Summary

CodeIgniter is a PHP full-stack web framework. Prior to 4.7.3, the ext_in upload validation rule in system/Validation/StrictRules/FileRules.php checked the MIME-derived guessed extension instead of the client-provided filename extension. As a result, an uploaded file named shell.php containing GIF-like content could pass validation such as uploaded[avatar]|is_image[avatar]|mime_in[avatar,image/gif]|ext_in[avatar,gif] because the detected MIME type maps to gif, even though the uploaded filename extension is php. Applications are impacted if they accept user-controlled uploads, rely on ext_in to validate the uploaded filename extension, save uploaded files using the original client filename with $file->move($path), store uploads in a web-accessible directory, and allow PHP or other executable files to run from that directory. In those conditions, this may lead to arbitrary code execution. This issue is fixed in version 4.7.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00775 56th percentileScored 2026-11-07
Fix Fixed CodeIgniter4 (codeigniter4): 4.7.3codeigniter4/framework (Packagist): 4.7.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
codeigniter4CodeIgniter4before 4.7.34.7.3Patch availableCNA
—codeigniter4/framework (Packagist)before 4.7.34.7.3Patch availableGHSA-2gr4-ppc7-7mhx
  • CodeIgniter4 Vendorcodeigniter4 Affected before 4.7.3 Fixed in 4.7.3 Patch available CNA
  • codeigniter4/framework (Packagist) Vendor— Affected before 4.7.3 Fixed in 4.7.3 Patch available GHSA-2gr4-ppc7-7mhx

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:*——codeigniter4
  • cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions — — ·codeigniter4

Remediation

  • Fix · CNA CodeIgniter4 (codeigniter4) Fixed in 4.7.3
  • Fix · GHSA-2gr4-ppc7-7mhx codeigniter4/framework (Packagist) Fixed in 4.7.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-48062
  2. 2026-10-03 Alias added: GHSA-2gr4-ppc7-7mhx

References

  • TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
  • TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
  • TI-2022-06025 Deserialization of Untrusted Data in Codeigniter4 CVSS 3.1CRITICAL 9.8
  • TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
  • TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
  • TI-2024-19671 CodeIgniter4 Language class DoS Vulnerability CVSS 3.1HIGH 7.5
See all 48 →

Sources