Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-066
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal Canvas allows Cross-Site Scripting (XSS). This issue affects Drupal Canvas versions: from 0.0.0 to 1.4.2, from 1.5.0 to 1.5.2, from 1.6.0 to 1.6.1, from 1.7.0 to 1.7.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Canvas | 0.0.0 to before 1.4.2; 1.5.0 to before 1.5.2; 1.6.0 to before 1.6.1; 1.7.0 to before 1.7.1 | 1.4.2, 1.5.2, 1.6.1, 1.7.1 | Patch available | CNA |
- Drupal Canvas VendorDrupal Affected 0.0.0 to before 1.4.2; 1.5.0 to before 1.5.2; 1.6.0 to before 1.6.1; 1.7.0 to before 1.7.1 Fixed in 1.4.2, 1.5.2, 1.6.1, 1.7.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal_canvas_project:drupal_canvas:*:*:*:*:*:drupal:*:* | before 1.4.2; 1.5.0 to before 1.5.2; 1.6.0 to before 1.6.1; 1.7.0 to before 1.7.1 | Vulnerable | Drupal Canvas Project |
- cpe:2.3:a:drupal_canvas_project:drupal_canvas:*:*:*:*:*:drupal:*:* Versions before 1.4.2; 1.5.0 to before 1.5.2; 1.6.0 to before 1.6.1; 1.7.0 to before 1.7.1 Vulnerable ·Drupal Canvas Project
Remediation
- Fix · CNA Drupal Canvas (Drupal) Fixed in 1.4.2, 1.5.2, 1.6.1, 1.7.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Canvas 1.4.2, 1.5.2 and 2 more versions
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-42167 Drupal Canvas - Moderately critical - Improper validation - SA-CONTRIB-2026-065Priority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2026-58588
- 2026-10-03 Alias added: GHSA-4jgx-vqf2-p9g9
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-58588 · CVE Program
- CVE-2026-58588 · NVD
- FIRST EPSS
- GHSA-4jgx-vqf2-p9g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences