Read the docs
TI-2026-46755 Aliases CVE-2026-65592GHSA-9wcp-9r3j-383q

n8n before 1.123.64 Stored DOM XSS via cachedResultUrl

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

n8n before 1.123.64, 2.29.8, and 2.30.1 contains a stored DOM cross-site scripting vulnerability in the Resource Locator component, which passes the workflow-persisted cachedResultUrl parameter to window.open() without scheme validation. An attacker with workflow creation/editing privileges can craft a workflow with a malicious (e.g., javascript:) scheme in cachedResultUrl; when a victim opens the crafted workflow and interacts with external links, the payload executes in the victim's browser.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00243 15th percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.64, 2.30.1, 2.29.8n8n (npm): 1.123.64, 2.30.1, 2.29.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.641.123.64Patch availableCNA
n8nn8n2.30.0 to before 2.30.12.30.1Patch availableCNA
n8nn8n2.0.0-rc.0 to before 2.29.82.29.8Patch availableCNA
—n8n (npm)before 1.123.641.123.64Patch availableGHSA-9wcp-9r3j-383q
—n8n (npm)2.30.0 to before 2.30.12.30.1Patch availableGHSA-9wcp-9r3j-383q
—n8n (npm)2.0.0-rc.0 to before 2.29.82.29.8Patch availableGHSA-9wcp-9r3j-383q
  • n8n Vendorn8n Affected before 1.123.64 Fixed in 1.123.64 Patch available CNA
  • n8n Vendorn8n Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available CNA
  • n8n Vendorn8n Affected 2.0.0-rc.0 to before 2.29.8 Fixed in 2.29.8 Patch available CNA
  • n8n (npm) Vendor— Affected before 1.123.64 Fixed in 1.123.64 Patch available GHSA-9wcp-9r3j-383q
  • n8n (npm) Vendor— Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available GHSA-9wcp-9r3j-383q
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.29.8 Fixed in 2.29.8 Patch available GHSA-9wcp-9r3j-383q

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:*before 1.123.64Vulnerablen8n
cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:*before 1.123.64Vulnerablen8n
cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:*2.0.0 to before 2.29.8Vulnerablen8n
cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:*2.0.0 to before 2.29.8Vulnerablen8n
cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:*2.30.0Vulnerablen8n
cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:*2.30.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 1.123.64 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 1.123.64 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions 2.0.0 to before 2.29.8 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions 2.0.0 to before 2.29.8 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* Versions 2.30.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.64
  • Fix · CNA n8n (n8n-io) Fixed in 2.30.1
  • Fix · CNA n8n (n8n-io) Fixed in 2.29.8
  • Fix · GHSA-9wcp-9r3j-383q n8n (npm) Fixed in 1.123.64 Advisory →
  • Fix · GHSA-9wcp-9r3j-383q n8n (npm) Fixed in 2.30.1 Advisory →
  • Fix · GHSA-9wcp-9r3j-383q n8n (npm) Fixed in 2.29.8 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    n8n-io n8n 2.29.8, 2.30.1

    13 records Highest priority Priority MEDIUM 3 MEDIUM, 10 LOW

    Other records, highest priority first

    • TI-2026-46758 n8n before 2.29.8 and 2.30.1 Privilege Escalation via Token ExchangePriority MEDIUM 42
    • TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
    • TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
  • Release ·

    n8n-io n8n 1.123.64

    9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW

    Other records, highest priority first

    • TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
    • TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
    • TI-2026-46454 n8n before 1.123.64, 2.29.8, and 2.30.1 Privilege Escalation via SSO Instance-RolePriority LOW 36

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-65592
  2. 2026-10-03 Alias added: GHSA-9wcp-9r3j-383q
  3. 2026-10-29 Affected versions changed · CNA

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources