n8n before 2.29.8 and 2.30.1 Privilege Escalation via Token Exchange
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
n8n before 2.30.1 and 2.29.8 assigns all Public API key scopes to JWTs issued through the Token Exchange module regardless of the acting user's role. On instances where the Token Exchange feature and Public API are enabled, a low-privileged user who can obtain a valid external JWT trusted by a configured issuer can use the resulting access token to invoke administrator-only Public API operations such as role escalation, user creation, and user deletion (role escalation requires an Advanced Permissions license), and, when unverified Community Package installation is enabled, achieve remote code execution.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | 2.30.0 to before 2.30.1 | 2.30.1 | Patch available | CNA |
| n8n | n8n | before 2.29.8 | 2.29.8 | Patch available | CNA |
| — | n8n (npm) | 2.30.0 to before 2.30.1 | 2.30.1 | Patch available | GHSA-777w-rpr6-c52h |
| — | n8n (npm) | before 2.29.8 | 2.29.8 | Patch available | GHSA-777w-rpr6-c52h |
- n8n Vendorn8n Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available CNA
- n8n Vendorn8n Affected before 2.29.8 Fixed in 2.29.8 Patch available CNA
- n8n (npm) Vendor— Affected 2.30.0 to before 2.30.1 Fixed in 2.30.1 Patch available GHSA-777w-rpr6-c52h
- n8n (npm) Vendor— Affected before 2.29.8 Fixed in 2.29.8 Patch available GHSA-777w-rpr6-c52h
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | before 2.29.8 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | before 2.29.8 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* | 2.30.0 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* | 2.30.0 | Vulnerable | n8n |
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 2.29.8 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 2.29.8 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:community:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.30.0:*:*:*:enterprise:node.js:*:* Versions 2.30.0 Vulnerable ·n8n
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 2.30.1
- Fix · CNA n8n (n8n-io) Fixed in 2.29.8
- Fix · GHSA-777w-rpr6-c52h n8n (npm) Fixed in 2.30.1 Advisory →
- Fix · GHSA-777w-rpr6-c52h n8n (npm) Fixed in 2.29.8 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
n8n-io n8n 2.29.8, 2.30.1
13 records Highest priority Priority MEDIUM 3 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2026-46754 n8n before 1.123.64 Sanitizer Bypass Remote Code ExecutionPriority MEDIUM 42
- TI-2026-46761 n8n before 1.123.64 Remote Code Execution via Git ClonePriority MEDIUM 40
- TI-2026-46755 n8n before 1.123.64 Stored DOM XSS via cachedResultUrlPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-65595
- 2026-10-03 Alias added: GHSA-777w-rpr6-c52h
- 2026-10-29 Affected versions changed · CNA
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-65595 · CVE Program
- CVE-2026-65595 · NVD
- FIRST EPSS
- GHSA-777w-rpr6-c52h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences