DXPR Builder: The AI Visual Page Builder for Drupal - Moderately critical - Information Disclosure - SA-CONTRIB-2026-112
Priority LOW 30CWE-201Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-201.
Summary
Insertion of Sensitive Information Into Sent Data vulnerability in Drupal DXPR Builder: The Best Editing (AI) Experience for Drupal allows Forceful Browsing. This issue affects DXPR Builder: The Best Editing (AI) Experience for Drupal versions: from 0.0.0 to 2.8.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0033 26th percentileScored 2026-11-07
Fix Fixed DXPR Builder: The Best Editing (AI) Experience for Drupal (Drupal): 2.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | DXPR Builder: The Best Editing (AI) Experience for Drupal | 0.0.0 to before 2.8.1 | 2.8.1 | Patch available | CNA |
- DXPR Builder: The Best Editing (AI) Experience for Drupal VendorDrupal Affected 0.0.0 to before 2.8.1 Fixed in 2.8.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dxpr_builder_project:dxpr_builder:*:*:*:*:*:drupal:*:* | before 2.8.1 | Vulnerable | Dxpr Builder Project |
- cpe:2.3:a:dxpr_builder_project:dxpr_builder:*:*:*:*:*:drupal:*:* Versions before 2.8.1 Vulnerable ·Dxpr Builder Project
Remediation
- Fix · CNA DXPR Builder: The Best Editing (AI) Experience for Drupal (Drupal) Fixed in 2.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-81162
- 2026-10-03 Alias added: GHSA-q42r-j7mq-j9mc
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-81162 · CVE Program
- CVE-2026-81162 · NVD
- FIRST EPSS
- GHSA-q42r-j7mq-j9mc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences