Monster Menus - Moderately critical - Cross-site Scripting - SA-CONTRIB-2026-116
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Monster Menus allows Stored XSS. This issue affects Monster Menus versions: from 0.0.0 to 9.5.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00256 17th percentileScored 2026-11-07
Fix Fixed Monster Menus (Drupal): 9.5.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Monster Menus | 0.0.0 to before 9.5.3 | 9.5.3 | Patch available | CNA |
- Monster Menus VendorDrupal Affected 0.0.0 to before 9.5.3 Fixed in 9.5.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:monster_menus_project:monster_menus:*:*:*:*:*:drupal:*:* | 6.x-6.19 – 6.x-6.64; 7.x-1.0 – 7.x-1.34; 9.0.0 to before 9.5.3 | Vulnerable | Monster Menus Project |
- cpe:2.3:a:monster_menus_project:monster_menus:*:*:*:*:*:drupal:*:* Versions 6.x-6.19 – 6.x-6.64; 7.x-1.0 – 7.x-1.34; 9.0.0 to before 9.5.3 Vulnerable ·Monster Menus Project
Remediation
- Fix · CNA Monster Menus (Drupal) Fixed in 9.5.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-81201
- 2026-10-03 Alias added: GHSA-679v-47xh-2343
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-81201 · CVE Program
- CVE-2026-81201 · NVD
- FIRST EPSS
- GHSA-679v-47xh-2343 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences