Drupal AI Translate missing authorization allows forceful browsing
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
Drupal AI Translate versions from 0.0.0 before 1.3.2 and from 1.4.0 before 1.4.1 are affected. A missing authorization check (CWE-862) lets users reach content they should not access by requesting pages directly, which is known as forceful browsing. An attacker with low privileges can gain limited access to data and change some of it, and a user must interact with the page for the attack to work.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Missing Authorization vulnerability in Drupal AI Translate allows Forceful Browsing. This issue affects AI Translate versions: from 0.0.0 to 1.3.2, from 1.4.0 to 1.4.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Drupal AI Translate to version 1.3.2 or 1.4.1. The fixes are described in Drupal security advisory SA-CONTRIB-2026-121.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA AI Translate (Drupal) Fixed in 1.3.2, 1.4.1
Timeline
- 2026-10-22 Threatist record created from CVE-2026-84913
- 2026-10-22 Alias added: GHSA-q2j4-w9mx-9w5r
- 2026-10-22 CVSS score added · CISA ADP
- 2026-10-22 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-84913 · CVE Program
- CVE-2026-84913 · NVD
- FIRST EPSS
- GHSA-q2j4-w9mx-9w5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences