SQL injection in Drupal amazee.ai Private AI Provider module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.
Summary
A SQL injection flaw (CWE-89) in the Drupal amazee.ai Private AI Provider module allows SQL injection through improperly neutralized special elements in SQL commands. The module versions from 0.0.0 before 1.3.7 and from 1.4.0 before 1.4.3 are affected. A remote attacker with no privileges and no user interaction can exploit it, with high complexity, to read sensitive data and modify some data.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal amazee.ai Private AI Provider allows SQL Injection. This issue affects amazee.ai Private AI Provider versions: from 0.0.0 to 1.3.7, from 1.4.0 to 1.4.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update amazee.ai Private AI Provider to version 1.3.7 or 1.4.3, which fix the flaw. The sources list no advisory identifier for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA amazee.ai Private AI Provider (Drupal) Fixed in 1.3.7, 1.4.3
Timeline
- 2026-10-22 Threatist record created from CVE-2026-87936
- 2026-10-22 Alias added: GHSA-28qc-3cgq-p54x
- 2026-10-22 CVSS score added · CISA ADP
- 2026-10-22 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-87936 · CVE Program
- CVE-2026-87936 · NVD
- FIRST EPSS
- GHSA-28qc-3cgq-p54x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences