Improper certificate validation in Drupal Cloud
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-295.
Summary
Drupal Cloud from 0.0.0 before 7.0.1 has an improper certificate validation flaw (CWE-295). A network attacker positioned between a client and the server can intercept and alter traffic in an adversary-in-the-middle attack. The attack is hard to carry out and needs no privileges or user interaction. It can partly expose and modify data.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Improper Certificate Validation vulnerability in Drupal Cloud allows Adversary in the Middle (AiTM). This issue affects Cloud versions: from 0.0.0 to 7.0.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Drupal Cloud to version 7.0.1 or later, which is the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Cloud (Drupal) Fixed in 7.0.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Cloud 7.0.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-79124 OS command injection in Drupal Cloud allows remote code executionPriority LOW 31
Timeline
- 2026-10-22 Threatist record created from CVE-2026-96375
- 2026-10-22 Alias added: GHSA-cxrv-m5j5-pwvm
- 2026-10-22 CVSS score added · CISA ADP
- 2026-10-22 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-96375 · CVE Program
- CVE-2026-96375 · NVD
- FIRST EPSS
- GHSA-cxrv-m5j5-pwvm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences