Privilege escalation in Drupal Editoria11y Accessibility Checker
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Drupal Editoria11y Accessibility Checker versions from 0.0.0 before 2.2.23 and from 3.0.0 before 3.0.9 are affected. The flaw is a privilege definition with unsafe actions (CWE-267), which lets a user gain privileges they should not have. An attacker with low privileges and no user interaction can exploit it to gain higher access, with a low impact on integrity. CISA has not added it to KEV, and its SSVC exploitation rating is none.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Privilege Defined With Unsafe Actions vulnerability in Drupal Editoria11y Accessibility Checker allows Privilege Escalation. This issue affects Editoria11y Accessibility Checker versions: from 0.0.0 to 2.2.23, from 3.0.0 to 3.0.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Editoria11y Accessibility Checker | 0.0.0 to before 2.2.23; 3.0.0 to before 3.0.9 | 2.2.23, 3.0.9 | Patch available | CNA |
- Editoria11y Accessibility Checker VendorDrupal Affected 0.0.0 to before 2.2.23; 3.0.0 to before 3.0.9 Fixed in 2.2.23, 3.0.9 Patch available CNA
Remediation
Update Editoria11y Accessibility Checker to version 2.2.23 for the 2.x branch or 3.0.9 for the 3.x branch.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Editoria11y Accessibility Checker (Drupal) Fixed in 2.2.23, 3.0.9
Timeline
- 2026-10-22 Threatist record created from CVE-2026-96390
- 2026-10-22 Alias added: GHSA-jp5c-5h2g-6r96
- 2026-10-22 CVSS score added · CISA ADP
- 2026-10-22 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-96390 · CVE Program
- CVE-2026-96390 · NVD
- FIRST EPSS
- GHSA-jp5c-5h2g-6r96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences