Incorrect authorization in Drupal Actstream allows forceful browsing
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
Drupal Actstream versions from 0.0.0 before 2.0.1 and from 2.1.0 before 2.1.1 contain an incorrect authorization flaw (CWE-863). A remote attacker without privileges can use forceful browsing to reach pages that should be restricted, which leads to limited disclosure and modification of data.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
Description from the CNA
Incorrect Authorization vulnerability in Drupal Actstream allows Forceful Browsing. This issue affects Actstream versions: from 0.0.0 to 2.0.1, from 2.1.0 to 2.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Drupal Actstream to version 2.0.1 or to version 2.1.1, depending on the installed release. The fix is described in Drupal security advisory SA-CONTRIB-2026-198.
Written with Claude Haiku 5.5 from the sources below · 2026-10-30
- Fix · CNA Actstream (Drupal) Fixed in 2.0.1, 2.1.1
Timeline
- 2026-10-30 Threatist record created from CVE-2026-107257
- 2026-10-30 Alias added: GHSA-49qr-j2v8-5wg8
- 2026-10-30 CVSS score added · CISA ADP
- 2026-10-30 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-107257 · CVE Program
- CVE-2026-107257 · NVD
- FIRST EPSS
- GHSA-49qr-j2v8-5wg8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences