Incorrect authorization in Drupal SmartLinker AI exposes information
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
Drupal SmartLinker AI versions from 0.0.0 before 1.0.3 contain an incorrect authorization flaw, CWE-863, that allows forceful browsing. A remote attacker with low privileges can access information they should not see, with a low impact on confidentiality and no impact on integrity or availability.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Description from the CNA
Incorrect Authorization vulnerability in Drupal SmartLinker AI allows Forceful Browsing. This issue affects SmartLinker AI versions: from 0.0.0 to 1.0.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Drupal SmartLinker AI to version 1.0.3. The sources list no advisory identifier for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
- Fix · CNA SmartLinker AI (Drupal) Fixed in 1.0.3
Timeline
- 2026-10-30 Threatist record created from CVE-2026-107307
- 2026-10-30 Alias added: GHSA-hvjg-3x8r-ppfw
- 2026-10-30 CVSS score added · CISA ADP
- 2026-10-30 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-107307 · CVE Program
- CVE-2026-107307 · NVD
- FIRST EPSS
- GHSA-hvjg-3x8r-ppfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences