Reflection injection in Drupal core allows remote code execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
Drupal core versions from 8.9.0 before 10.6.19, from 11.0.0 before 11.3.19, from 11.4.0 before 11.4.10, and from 12.0.0-alpha1 before 12.0.0-beta2 are affected. Unsafe reflection (CWE-470) lets externally controlled input select classes or code to run. An unauthenticated remote attacker can exploit this with high complexity to take control of the affected system.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Drupal Drupal core allows Reflection Injection. This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal core | 8.9.0 to before 10.6.19; 11.0.0 to before 11.3.19; 11.4.0 to before 11.4.10; 12.0.0-alpha1 to before 12.0.0-beta2 | 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2 | Patch available | CNA |
- Drupal core VendorDrupal Affected 8.9.0 to before 10.6.19; 11.0.0 to before 11.3.19; 11.4.0 to before 11.4.10; 12.0.0-alpha1 to before 12.0.0-beta2 Fixed in 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2 Patch available CNA
Remediation
Upgrade Drupal core to 10.6.19, 11.3.19, 11.4.10 or 12.0.0-beta2, depending on the release line in use. The sources do not list a vendor advisory identifier for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Drupal core (Drupal) Fixed in 10.6.19, 11.3.19, 11.4.10, 12.0.0-beta2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal core 10.6.19, 11.3.19 and 2 more versions
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-82855 Cross-site scripting in Drupal core allows script injectionPriority LOW 28
- TI-2026-82854 Cross-site scripting in Drupal corePriority LOW 28
Timeline
- 2026-10-30 Threatist record created from CVE-2026-108097
- 2026-10-30 Alias added: GHSA-x75q-mvwp-2h36
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-108097 · CVE Program
- CVE-2026-108097 · NVD
- FIRST EPSS
- GHSA-x75q-mvwp-2h36 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences