Cross-site scripting in Drupal Gin Admin Theme
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Drupal Gin Admin Theme versions from 0.0.0 before 4.1.4 and from 5.0.0 before 5.0.16 are affected. Improper neutralization of input during web page generation (CWE-79) allows cross-site scripting. An attacker with low privileges needs a user to interact with a crafted page, and the attack can affect confidentiality, integrity and availability at low impact levels.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Gin Admin Theme allows Cross-Site Scripting (XSS). This issue affects Gin Admin Theme versions: from 0.0.0 to 4.1.4, from 5.0.0 to 5.0.16.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update Gin Admin Theme to version 4.1.4 or to version 5.0.16. The fix is listed in the Drupal security advisory SA-CONTRIB-2026-219.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Gin Admin Theme (Drupal) Fixed in 4.1.4, 5.0.16
Timeline
- 2026-10-30 Threatist record created from CVE-2026-110738
- 2026-10-30 Alias added: GHSA-pgj3-xvxh-67cp
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-110738 · CVE Program
- CVE-2026-110738 · NVD
- FIRST EPSS
- GHSA-pgj3-xvxh-67cp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences