Stored cross-site scripting in Drupal Zero Point
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
Drupal Zero Point versions from 0.0.0 before 1.30.0 and from 2.0.0 before 2.0.1 are affected. Improper neutralization of input during web page generation (CWE-79) allows stored cross-site scripting. An attacker can store malicious script that runs in the browser of a user who views the affected content, with user interaction required and a changed scope.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Zero Point allows Stored XSS. This issue affects Zero Point versions: from 0.0.0 to 1.30.0, from 2.0.0 to 2.0.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Drupal Zero Point to version 1.30.0 for the 1.x branch or to version 2.0.1 for the 2.x branch. The sources list no fixed version for Drupal Zero Point beyond these releases.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Zero Point (Drupal) Fixed in 1.30.0, 2.0.1
Timeline
- 2026-10-30 Threatist record created from CVE-2026-114528
- 2026-10-30 Alias added: GHSA-g5xr-324v-xf2r
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-114528 · CVE Program
- CVE-2026-114528 · NVD
- FIRST EPSS
- GHSA-g5xr-324v-xf2r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences