Read the docs

Dopup Incorrect Authorization Enables Information Disclosure

Priority LOW 22CWE-863Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from CNA. Impact type from CWE-863.

Summary

Incorrect authorization in the Drupal Dopup module lets users reach content they should not see through forceful browsing. Versions from 0.0.0 before 1.0.7 are affected. The flaw is tracked under CWE-863. The sources do not describe the required privileges or the exact impact beyond information disclosure.

Written with Claude Haiku 5.5 from the sources below · 2026-10-30

Description from the CNA

Incorrect Authorization vulnerability in Drupal Dopup allows Forceful Browsing. This issue affects Dopup versions: from 0.0.0 to 1.0.7.

Why it matters now

EPSS 0.00228 13th percentileScored 2026-11-07
Fix Fixed Dopup (Drupal): 1.0.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDopup0.0.0 to before 1.0.71.0.7Patch availableCNA
  • Dopup VendorDrupal Affected 0.0.0 to before 1.0.7 Fixed in 1.0.7 Patch available CNA

Remediation

Upgrade Drupal Dopup to version 1.0.7, the fixed version.

Written with Claude Haiku 5.5 from the sources below · 2026-10-30

  • Fix · CNA Dopup (Drupal) Fixed in 1.0.7

Timeline

  1. 2026-10-30 Threatist record created from CVE-2026-114530
  2. 2026-10-30 Alias added: GHSA-j7q7-fjvx-wqxr

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 941 →

Sources