Stored cross-site scripting in Drupal Swiper formatter
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from CNA. Impact type from CWE-79.
Summary
Drupal Swiper formatter versions from 0.0.0 before 2.1.2 and from 3.0.1 before 3.1.0 are affected. Improper neutralization of input during web page generation (CWE-79) lets stored cross-site scripting occur. The flaw lets injected script persist in stored content and run in pages that display it.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Swiper formatter allows Stored XSS. This issue affects Swiper formatter versions: from 0.0.0 to 2.1.2, from 3.0.1 to 3.1.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
Upgrade Swiper formatter to version 2.1.2 or 3.1.0, which fix the issue as described in Drupal advisory SA-CONTRIB-2026-228.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA Swiper formatter (Drupal) Fixed in 2.1.2, 3.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Swiper formatter 2.1.2, 3.1.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-82869 Missing authorization in Drupal Swiper formatter leaks informationPriority LOW 23
Timeline
- 2026-10-30 Threatist record created from CVE-2026-114531
- 2026-10-30 Alias added: GHSA-qq39-577c-fc5w
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-114531 · CVE Program
- CVE-2026-114531 · NVD
- FIRST EPSS
- GHSA-qq39-577c-fc5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences