Cross-site scripting in Drupal UI Icons
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from CNA. Impact type from CWE-79.
Summary
Drupal UI Icons versions from 0.0.0 before 1.1.3 and from 2.0.0 before 2.0.2 are affected. Improper neutralization of input during web page generation (CWE-79) lets cross-site scripting occur in the module.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal UI Icons allows Cross-Site Scripting (XSS). This issue affects UI Icons versions: from 0.0.0 to 1.1.3, from 2.0.0 to 2.0.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
Update Drupal UI Icons to version 1.1.3 on the 1.x line and to version 2.0.2 on the 2.x line. The Drupal security advisory SA-CONTRIB-2026-230 covers this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA UI Icons (Drupal) Fixed in 1.1.3, 2.0.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal UI Icons 1.1.3, 2.0.2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-82861 Cross-site scripting in Drupal UI IconsPriority LOW 30
Timeline
- 2026-10-30 Threatist record created from CVE-2026-114532
- 2026-10-30 Alias added: GHSA-rxw8-5346-9f4r
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-114532 · CVE Program
- CVE-2026-114532 · NVD
- FIRST EPSS
- GHSA-rxw8-5346-9f4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences