Insecure storage in Drupal AI module exposes embedded sensitive data
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-922.
Summary
Drupal AI (Artificial Intelligence) versions from 0.0.0 before 1.4.11 and from 1.5.0 before 1.5.2 are affected. Insecure storage of sensitive information (CWE-922) allows embedded sensitive data to be retrieved. A remote attacker with low privileges can retrieve this data, but attack complexity is high.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Insecure Storage of Sensitive Information vulnerability in Drupal AI (Artificial Intelligence) allows Retrieve Embedded Sensitive Data. This issue affects AI (Artificial Intelligence) versions: from 0.0.0 to 1.4.11, from 1.5.0 to 1.5.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | AI (Artificial Intelligence) | 0.0.0 to before 1.4.11; 1.5.0 to before 1.5.2 | 1.4.11, 1.5.2 | Patch available | CNA |
- AI (Artificial Intelligence) VendorDrupal Affected 0.0.0 to before 1.4.11; 1.5.0 to before 1.5.2 Fixed in 1.4.11, 1.5.2 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:artificial_intelligence_project:artificial_intelligence:*:*:*:*:*:*:*:* | — | — | Artificial Intelligence Project |
- cpe:2.3:a:artificial_intelligence_project:artificial_intelligence:*:*:*:*:*:*:*:* Versions — — ·Artificial Intelligence Project
Remediation
Upgrade Drupal AI (Artificial Intelligence) to version 1.4.11 or 1.5.2, which fix the flaw as described in advisory SA-CONTRIB-2026-271.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA AI (Artificial Intelligence) (Drupal) Fixed in 1.4.11, 1.5.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal AI (Artificial Intelligence) 1.4.11, 1.5.2
8 records Highest priority Priority LOW 8 LOW
Other records, highest priority first
- TI-2026-82898 Cross-site scripting in Drupal AI (Artificial Intelligence) modulePriority LOW 30
- TI-2026-82901 Cross-site scripting in Drupal AI (Artificial Intelligence) modulePriority LOW 28
- TI-2026-82896 Cross-site scripting in Drupal AI (Artificial Intelligence) modulePriority LOW 28
Timeline
- 2026-10-30 Threatist record created from CVE-2026-118551
- 2026-10-30 Alias added: GHSA-c2vh-345q-88w5
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-118551 · CVE Program
- CVE-2026-118551 · NVD
- FIRST EPSS
- GHSA-c2vh-345q-88w5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences