Cross-site request forgery in Drupal Commerce Stripe
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
Drupal Commerce Stripe from 2.0.0 before 2.2.3 contains a cross-site request forgery flaw (CWE-352) that lets a remote attacker make a logged-in user's browser submit unintended requests. The attacker needs no privileges, but a victim must visit a page the attacker controls. A successful attack can affect confidentiality, integrity and availability to a limited degree.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Commerce Stripe allows Cross Site Request Forgery. This issue affects Commerce Stripe versions: from 2.0.0 to 2.2.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update Drupal Commerce Stripe to version 2.2.3, which fixes the issue, as described in SA-CONTRIB-2026-263.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Commerce Stripe (Drupal) Fixed in 2.2.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Commerce Stripe 2.2.3
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-82909 Cross-site scripting in Drupal Commerce StripePriority LOW 22
Timeline
- 2026-10-30 Threatist record created from CVE-2026-118558
- 2026-10-30 Alias added: GHSA-m8m7-pgw4-356q
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-118558 · CVE Program
- CVE-2026-118558 · NVD
- FIRST EPSS
- GHSA-m8m7-pgw4-356q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences