Incorrect authorization in Drupal Bulk Update User Roles module
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-863.
Summary
Incorrect authorization in the Drupal Bulk Update User Roles module from 0.0.0 before 1.0.5 lets attackers reach functionality they should not access through forceful browsing. An attacker with high privileges on the site can exploit this flaw remotely without user interaction, which affects confidentiality, integrity and availability to a limited degree. The weakness is classified as CWE-863.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Incorrect Authorization vulnerability in Drupal Bulk Update User Roles allows Forceful Browsing. This issue affects Bulk Update User Roles versions: from 0.0.0 to 1.0.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Drupal Bulk Update User Roles users should update to version 1.0.5, which is the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Bulk Update User Roles (Drupal) Fixed in 1.0.5
Timeline
- 2026-10-30 Threatist record created from CVE-2026-118567
- 2026-10-30 Alias added: GHSA-jqgx-wgx8-pq4r
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-118567 · CVE Program
- CVE-2026-118567 · NVD
- FIRST EPSS
- GHSA-jqgx-wgx8-pq4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences