Drupal Content Sync exposes embedded sensitive data through insecure storage
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-922.
Summary
Drupal Content Sync (content-sync.io) stores sensitive information insecurely (CWE-922), which lets an attacker retrieve embedded sensitive data. Versions from 0.0.0 before 3.2.2 are affected. The CVSS 3.1 base score is 3.3 (LOW), and exploitation requires network access, high attack complexity and high privileges. CISA has not added it to KEV.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
Insecure Storage of Sensitive Information vulnerability in Drupal Content Sync (content-sync.io) allows Retrieve Embedded Sensitive Data. This issue affects Content Sync (content-sync.io) versions: from 0.0.0 to 3.2.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update Content Sync to version 3.2.2 or later, as described in Drupal advisory SA-CONTRIB-2026-291.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Content Sync (content-sync.io) (Drupal) Fixed in 3.2.2
Timeline
- 2026-10-30 Threatist record created from CVE-2026-118568
- 2026-10-30 Alias added: GHSA-whvp-fx3x-2r9q
- 2026-11-06 CVSS score added · CISA ADP
- 2026-11-06 CISA SSVC decision points changed
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2026-118568 · CVE Program
- CVE-2026-118568 · NVD
- FIRST EPSS
- GHSA-whvp-fx3x-2r9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences