Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

27 records

TI-2024-09768 CVE-2024-10545 · GHSA-2g2g-m4v5-68cr

NextGEN Gallery < 3.59.9 - Admin+ Stored XSS

Priority MEDIUM 50

The Photo Gallery, Sliders, Proofing and WordPress plugin before 3.59.9 does not sanitise and escape some of its Image settings, which could allow high privilege users such as Admin to perform Stored Cross-Site Scripting…

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.00346 Published 2025-02-25 Fixed in 3.59.9 CWE-79
Priority LOW 22

The Photo Gallery, Sliders, Proofing and WordPress plugin before 3.59.5 does not sanitise and escape some of its Images settings, which could allow high privilege users such as Admin to perform Stored Cross-Site Scriptin…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00448 Published 2024-11-25 Fixed in 3.59.5 CWE-79
Priority LOW 26

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Imagely NextGEN Gallery allows Stored XSS.This issue affects NextGEN Gallery: from n/a through 3.59.3.

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00315 Published 2024-08-01 No fix listed CWE-79
Priority MEDIUM 60

The Photo Gallery, Sliders, Proofing and WordPress plugin before 3.59.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attac…

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00375 Published 2024-07-13 Fixed in 3.59.3 CWE-79
Priority MEDIUM 53

The NextGEN Gallery WordPress plugin before 3.59.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html…

CVSS 3.1MEDIUM 4.3 Network High privileges User interaction EPSS 0.0039 Published 2024-05-17 Fixed in 3.59.1 CWE-79
Priority MEDIUM 57

The WordPress Gallery Plugin – NextGEN Gallery plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the get_item function in versions up to, and including, 3.59.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.38023 Published 2024-04-09 No fix listed CWE-862
Priority LOW 38

Cross-Site Request Forgery (CSRF) vulnerability in Imagely WordPress Gallery Plugin – NextGEN Gallery allows Cross Site Request Forgery.This issue affects WordPress Gallery Plugin – NextGEN Gallery: from n/a through 3.37…

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00269 Published 2023-11-30 No fix listed CWE-352
Priority MEDIUM 56

The WordPress Gallery Plugin WordPress plugin before 3.39 does not validate some block attributes before using them to generate paths passed to include function/s, allowing Admin users to perform LFI attacks

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.0096 Published 2023-10-16 Fixed in 3.39
Priority HIGH 67

The WordPress Gallery Plugin WordPress plugin before 3.39 is vulnerable to Arbitrary File Read and Delete due to a lack of input parameter validation in the `gallery_edit` function, allowing an attacker to access arbitra…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01021 Published 2023-10-16 Fixed in 3.39 CWE-552
Priority HIGH 72

The WordPress Gallery Plugin WordPress plugin before 3.39 is vulnerable to PHAR Deserialization due to a lack of input parameter validation in the `gallery_edit` function, allowing an attacker to access arbitrary resourc…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00846 Published 2023-10-16 Fixed in 3.39
Priority MEDIUM 42

In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01991 Published 2022-07-07 No fix listed CWE-434
Priority LOW 30

In nextgen-galery wordpress plugin before 2.0.77.3 there are two vulnerabilities which can allow an attacker to gain full access over the web application.

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00698 Published 2022-07-07 No fix listed CWE-434
Priority LOW 29

In the eCommerce module of the NextGEN Gallery Pro WordPress plugin before 3.1.11, there is an action to call get_cart_items via photocrati_ajax , after that the settings[shipping_address][name] is able to inject malicio…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00867 Published 2021-05-05 Fixed in 3.1.11 CWE-79
Priority LOW 38

The Imagely NextGen Gallery plugin for Wordpress prior to version 2.1.57 does not properly validate user input in the cssfile parameter of a HTTP POST request, which may allow an authenticated user to read arbitrary file…

CVSS 3.0HIGH 7.5 Network Low privileges No interaction EPSS 0.02506 Published 2018-07-13 Fixed in 2.1.57 CWE-98
Load more