The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node…
Priority LOW 37CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules.
Why it matters now
EPSS 0.02207 82nd percentileScored 2026-11-07
Fix Fixed drupal/drupal (Packagist): 5.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/drupal (Packagist) | 5.0 to before 5.11 | 5.11 | Patch available | GHSA-ph2j-5hxq-gxrr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/drupal (Packagist) Vendor— Affected 5.0 to before 5.11 Fixed in 5.11 Patch available GHSA-ph2j-5hxq-gxrr
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | up to 5.10 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.0:beta1:*:*:*:*:*:* | 5.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.0:beta2:*:*:*:*:*:* | 5.0 beta2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.0:rc1:*:*:*:*:*:* | 5.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.0:rc2:*:*:*:*:*:* | 5.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.1:*:*:*:*:*:*:* | 5.1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.2:*:*:*:*:*:*:* | 5.2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.3:*:*:*:*:*:*:* | 5.3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.4:*:*:*:*:*:*:* | 5.4 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions up to 5.10 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.0:beta1:*:*:*:*:*:* Versions 5.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.0:beta2:*:*:*:*:*:* Versions 5.0 beta2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.0:rc1:*:*:*:*:*:* Versions 5.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.0:rc2:*:*:*:*:*:* Versions 5.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.1:*:*:*:*:*:*:* Versions 5.1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.2:*:*:*:*:*:*:* Versions 5.2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.3:*:*:*:*:*:*:* Versions 5.3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.4:*:*:*:*:*:*:* Versions 5.4 Vulnerable ·Drupal
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:5.5:*:*:*:*:*:*:* | 5.5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.6:*:*:*:*:*:*:* | 5.6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.7:*:*:*:*:*:*:* | 5.7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.8:*:*:*:*:*:*:* | 5.8 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:5.9:*:*:*:*:*:*:* | 5.9 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:5.5:*:*:*:*:*:*:* Versions 5.5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.6:*:*:*:*:*:*:* Versions 5.6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.7:*:*:*:*:*:*:* Versions 5.7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.8:*:*:*:*:*:*:* Versions 5.8 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:5.9:*:*:*:*:*:*:* Versions 5.9 Vulnerable ·Drupal
Remediation
- Fix · GHSA-ph2j-5hxq-gxrr drupal/drupal (Packagist) Fixed in 5.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2008-4793
- 2026-10-03 Alias added: GHSA-ph2j-5hxq-gxrr
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2008-4793 · CVE Program
- CVE-2008-4793 · NVD
- FIRST EPSS
- GHSA-ph2j-5hxq-gxrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences