Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow…
Priority LOW 14CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.18 allow remote authenticated users with certain privileges to inject arbitrary web script or HTML via (1) an action description, (2) an action message, (3) a node, or (4) a taxonomy term, related to the actions feature and the trigger module.
Why it matters now
EPSS 0.01371 72nd percentileScored 2026-11-07
Fix Fixed drupal/drupal (Packagist): 6.18
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/drupal (Packagist) | 6.0 to before 6.18 | 6.18 | Patch available | GHSA-pjmx-4gc6-hwv8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/drupal (Packagist) Vendor— Affected 6.0 to before 6.18 Fixed in 6.18 Patch available GHSA-pjmx-4gc6-hwv8
CPE configurations NVD · 27
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:beta1:*:*:*:*:*:* | 6.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:beta2:*:*:*:*:*:* | 6.0 beta2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:beta3:*:*:*:*:*:* | 6.0 beta3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:beta4:*:*:*:*:*:* | 6.0 beta4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:dev:*:*:*:*:*:* | 6.0 dev | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:rc1:*:*:*:*:*:* | 6.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:rc2:*:*:*:*:*:* | 6.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:rc3:*:*:*:*:*:* | 6.0 rc3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.0:rc4:*:*:*:*:*:* | 6.0 rc4 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:beta1:*:*:*:*:*:* Versions 6.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:beta2:*:*:*:*:*:* Versions 6.0 beta2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:beta3:*:*:*:*:*:* Versions 6.0 beta3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:beta4:*:*:*:*:*:* Versions 6.0 beta4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:dev:*:*:*:*:*:* Versions 6.0 dev Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:rc1:*:*:*:*:*:* Versions 6.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:rc2:*:*:*:*:*:* Versions 6.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:rc3:*:*:*:*:*:* Versions 6.0 rc3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.0:rc4:*:*:*:*:*:* Versions 6.0 rc4 Vulnerable ·Drupal
Show 17 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:6.1:*:*:*:*:*:*:* | 6.1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.2:*:*:*:*:*:*:* | 6.2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.3:*:*:*:*:*:*:* | 6.3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.4:*:*:*:*:*:*:* | 6.4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.5:*:*:*:*:*:*:* | 6.5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.6:*:*:*:*:*:*:* | 6.6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.7:*:*:*:*:*:*:* | 6.7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.8:*:*:*:*:*:*:* | 6.8 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.9:*:*:*:*:*:*:* | 6.9 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.10:*:*:*:*:*:*:* | 6.10 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.11:*:*:*:*:*:*:* | 6.11 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.12:*:*:*:*:*:*:* | 6.12 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.13:*:*:*:*:*:*:* | 6.13 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.14:*:*:*:*:*:*:* | 6.14 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.15:*:*:*:*:*:*:* | 6.15 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.16:*:*:*:*:*:*:* | 6.16 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:6.17:*:*:*:*:*:*:* | 6.17 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:6.1:*:*:*:*:*:*:* Versions 6.1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.2:*:*:*:*:*:*:* Versions 6.2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.3:*:*:*:*:*:*:* Versions 6.3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.4:*:*:*:*:*:*:* Versions 6.4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.5:*:*:*:*:*:*:* Versions 6.5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.6:*:*:*:*:*:*:* Versions 6.6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.7:*:*:*:*:*:*:* Versions 6.7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.8:*:*:*:*:*:*:* Versions 6.8 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.9:*:*:*:*:*:*:* Versions 6.9 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.10:*:*:*:*:*:*:* Versions 6.10 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.11:*:*:*:*:*:*:* Versions 6.11 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.12:*:*:*:*:*:*:* Versions 6.12 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.13:*:*:*:*:*:*:* Versions 6.13 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.14:*:*:*:*:*:*:* Versions 6.14 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.15:*:*:*:*:*:*:* Versions 6.15 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.16:*:*:*:*:*:*:* Versions 6.16 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:6.17:*:*:*:*:*:*:* Versions 6.17 Vulnerable ·Drupal
Remediation
- Fix · GHSA-pjmx-4gc6-hwv8 drupal/drupal (Packagist) Fixed in 6.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2010-3094
- 2026-10-03 Alias added: GHSA-pjmx-4gc6-hwv8
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2010-3094 · CVE Program
- CVE-2010-3094 · NVD
- FIRST EPSS
- GHSA-pjmx-4gc6-hwv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences