Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions…
Priority LOW 38CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.
Why it matters now
EPSS 0.03056 87th percentileScored 2026-11-07
Fix Fixed drupal/core (Packagist): 7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 7.0 to before 7.3 | 7.3 | Patch available | GHSA-96vx-qf28-6f8m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 7.0 to before 7.3 Fixed in 7.3 Patch available GHSA-96vx-qf28-6f8m
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha1:*:*:*:*:*:* | 7.0 alpha1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha2:*:*:*:*:*:* | 7.0 alpha2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha3:*:*:*:*:*:* | 7.0 alpha3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha4:*:*:*:*:*:* | 7.0 alpha4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha5:*:*:*:*:*:* | 7.0 alpha5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha6:*:*:*:*:*:* | 7.0 alpha6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha7:*:*:*:*:*:* | 7.0 alpha7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:beta1:*:*:*:*:*:* | 7.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:beta2:*:*:*:*:*:* | 7.0 beta2 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha1:*:*:*:*:*:* Versions 7.0 alpha1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha2:*:*:*:*:*:* Versions 7.0 alpha2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha3:*:*:*:*:*:* Versions 7.0 alpha3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha4:*:*:*:*:*:* Versions 7.0 alpha4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha5:*:*:*:*:*:* Versions 7.0 alpha5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha6:*:*:*:*:*:* Versions 7.0 alpha6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha7:*:*:*:*:*:* Versions 7.0 alpha7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:beta1:*:*:*:*:*:* Versions 7.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:beta2:*:*:*:*:*:* Versions 7.0 beta2 Vulnerable ·Drupal
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:7.0:beta3:*:*:*:*:*:* | 7.0 beta3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:dev:*:*:*:*:*:* | 7.0 dev | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.1:*:*:*:*:*:*:* | 7.1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.2:*:*:*:*:*:*:* | 7.2 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:7.0:beta3:*:*:*:*:*:* Versions 7.0 beta3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:dev:*:*:*:*:*:* Versions 7.0 dev Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.1:*:*:*:*:*:*:* Versions 7.1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.2:*:*:*:*:*:*:* Versions 7.2 Vulnerable ·Drupal
Remediation
- Fix · GHSA-96vx-qf28-6f8m drupal/core (Packagist) Fixed in 7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2011-2687
- 2026-10-03 Alias added: GHSA-96vx-qf28-6f8m
References
Other 5
- [oss-security] 20110712 Re: CVE Request -- Drupal 7 -- Access bypass in node listings (SA-CORE-2011-002)
- [oss-security] 20110711 CVE Request -- Drupal 7 -- Access bypass in node listings (SA-CORE-2011-002)
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=633385
- https://bugzilla.redhat.com/show_bug.cgi?id=717874
- https://web.archive.org/web/20110710024036/http://www.securityfocus.com/bid/48505
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2011-2687 · CVE Program
- CVE-2011-2687 · NVD
- FIRST EPSS
- GHSA-96vx-qf28-6f8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences