Open redirect vulnerability in the Form API in Drupal 7.x before 7.13 allows remote…
Priority LOW 29CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Partial · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
Open redirect vulnerability in the Form API in Drupal 7.x before 7.13 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via crafted parameters in a destination URL.
Why it matters now
EPSS 0.01362 71st percentileScored 2026-11-07
Fix Fixed drupal/drupal (Packagist): 7.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/drupal (Packagist) | 7.0 to before 7.13 | 7.13 | Patch available | GHSA-wwrm-8947-4m6c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.13 Fixed in 7.13 Patch available GHSA-wwrm-8947-4m6c
CPE configurations NVD · 29
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha1:*:*:*:*:*:* | 7.0 alpha1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha2:*:*:*:*:*:* | 7.0 alpha2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha3:*:*:*:*:*:* | 7.0 alpha3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha4:*:*:*:*:*:* | 7.0 alpha4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha5:*:*:*:*:*:* | 7.0 alpha5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha6:*:*:*:*:*:* | 7.0 alpha6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha7:*:*:*:*:*:* | 7.0 alpha7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:beta1:*:*:*:*:*:* | 7.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:beta2:*:*:*:*:*:* | 7.0 beta2 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha1:*:*:*:*:*:* Versions 7.0 alpha1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha2:*:*:*:*:*:* Versions 7.0 alpha2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha3:*:*:*:*:*:* Versions 7.0 alpha3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha4:*:*:*:*:*:* Versions 7.0 alpha4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha5:*:*:*:*:*:* Versions 7.0 alpha5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha6:*:*:*:*:*:* Versions 7.0 alpha6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha7:*:*:*:*:*:* Versions 7.0 alpha7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:beta1:*:*:*:*:*:* Versions 7.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:beta2:*:*:*:*:*:* Versions 7.0 beta2 Vulnerable ·Drupal
Show 19 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:7.0:beta3:*:*:*:*:*:* | 7.0 beta3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:dev:*:*:*:*:*:* | 7.0 dev | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.1:*:*:*:*:*:*:* | 7.1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.2:*:*:*:*:*:*:* | 7.2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.3:*:*:*:*:*:*:* | 7.3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.4:*:*:*:*:*:*:* | 7.4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.7:*:*:*:*:*:*:* | 7.7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.8:*:*:*:*:*:*:* | 7.8 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.9:*:*:*:*:*:*:* | 7.9 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.12:*:*:*:*:*:*:* | 7.12 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.x-dev:*:*:*:*:*:*:* | 7.x-dev | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:7.0:beta3:*:*:*:*:*:* Versions 7.0 beta3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:dev:*:*:*:*:*:* Versions 7.0 dev Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.1:*:*:*:*:*:*:* Versions 7.1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.2:*:*:*:*:*:*:* Versions 7.2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.7:*:*:*:*:*:*:* Versions 7.7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.8:*:*:*:*:*:*:* Versions 7.8 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.9:*:*:*:*:*:*:* Versions 7.9 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.12:*:*:*:*:*:*:* Versions 7.12 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.x-dev:*:*:*:*:*:*:* Versions 7.x-dev Vulnerable ·Drupal
Remediation
- Fix · GHSA-wwrm-8947-4m6c drupal/drupal (Packagist) Fixed in 7.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-1589
- 2026-10-03 Alias added: GHSA-wwrm-8947-4m6c
References
Advisory 5
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2012-1589 · CVE Program
- CVE-2012-1589 · NVD
- FIRST EPSS
- GHSA-wwrm-8947-4m6c · GitHub Advisory Database · CC BY 4.0
- CVE-2012-1589 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences