Drupal 7.x before 7.14 does not properly restrict access to nodes in a list when using a…
Priority LOW 23CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
Drupal 7.x before 7.14 does not properly restrict access to nodes in a list when using a "contributed node access module," which allows remote authenticated users with the "Access the content overview page" permission to read all published nodes by accessing the admin/content page.
Why it matters now
EPSS 0.01881 79th percentileScored 2026-11-07
Fix Fixed drupal/drupal (Packagist): 7.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/drupal (Packagist) | 7.0 to before 7.14 | 7.14 | Patch available | GHSA-vpm6-h53m-x2xf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.14 Fixed in 7.14 Patch available GHSA-vpm6-h53m-x2xf
CPE configurations NVD · 30
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha1:*:*:*:*:*:* | 7.0 alpha1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha2:*:*:*:*:*:* | 7.0 alpha2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha3:*:*:*:*:*:* | 7.0 alpha3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha4:*:*:*:*:*:* | 7.0 alpha4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha5:*:*:*:*:*:* | 7.0 alpha5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha6:*:*:*:*:*:* | 7.0 alpha6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:alpha7:*:*:*:*:*:* | 7.0 alpha7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:beta1:*:*:*:*:*:* | 7.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:beta2:*:*:*:*:*:* | 7.0 beta2 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha1:*:*:*:*:*:* Versions 7.0 alpha1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha2:*:*:*:*:*:* Versions 7.0 alpha2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha3:*:*:*:*:*:* Versions 7.0 alpha3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha4:*:*:*:*:*:* Versions 7.0 alpha4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha5:*:*:*:*:*:* Versions 7.0 alpha5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha6:*:*:*:*:*:* Versions 7.0 alpha6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:alpha7:*:*:*:*:*:* Versions 7.0 alpha7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:beta1:*:*:*:*:*:* Versions 7.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:beta2:*:*:*:*:*:* Versions 7.0 beta2 Vulnerable ·Drupal
Show 20 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:7.0:beta3:*:*:*:*:*:* | 7.0 beta3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:dev:*:*:*:*:*:* | 7.0 dev | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc1:*:*:*:*:*:* | 7.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc2:*:*:*:*:*:* | 7.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc3:*:*:*:*:*:* | 7.0 rc3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.0:rc4:*:*:*:*:*:* | 7.0 rc4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.1:*:*:*:*:*:*:* | 7.1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.2:*:*:*:*:*:*:* | 7.2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.3:*:*:*:*:*:*:* | 7.3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.4:*:*:*:*:*:*:* | 7.4 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.7:*:*:*:*:*:*:* | 7.7 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.8:*:*:*:*:*:*:* | 7.8 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.9:*:*:*:*:*:*:* | 7.9 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.12:*:*:*:*:*:*:* | 7.12 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.13:*:*:*:*:*:*:* | 7.13 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:7.x-dev:*:*:*:*:*:*:* | 7.x-dev | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:7.0:beta3:*:*:*:*:*:* Versions 7.0 beta3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:dev:*:*:*:*:*:* Versions 7.0 dev Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc1:*:*:*:*:*:* Versions 7.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc2:*:*:*:*:*:* Versions 7.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc3:*:*:*:*:*:* Versions 7.0 rc3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.0:rc4:*:*:*:*:*:* Versions 7.0 rc4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.1:*:*:*:*:*:*:* Versions 7.1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.2:*:*:*:*:*:*:* Versions 7.2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.7:*:*:*:*:*:*:* Versions 7.7 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.8:*:*:*:*:*:*:* Versions 7.8 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.9:*:*:*:*:*:*:* Versions 7.9 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.12:*:*:*:*:*:*:* Versions 7.12 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.13:*:*:*:*:*:*:* Versions 7.13 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:7.x-dev:*:*:*:*:*:*:* Versions 7.x-dev Vulnerable ·Drupal
Remediation
- Fix · GHSA-vpm6-h53m-x2xf drupal/drupal (Packagist) Fixed in 7.14 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2012-2153
- 2026-10-03 Alias added: GHSA-vpm6-h53m-x2xf
References
Advisory 3
Other 4
- http://drupalcode.org/project/drupal.git/commit/c6d2b8311b82fe78d18732f01a68ceca3dea50af
- http://drupal.org/node/1558478
- https://web.archive.org/web/20150523060428/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2013:074/?name=MDVSA-2013:074
- https://web.archive.org/web/20200229101926/http://www.securityfocus.com/bid/53362
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2012-2153 · CVE Program
- CVE-2012-2153 · NVD
- FIRST EPSS
- GHSA-vpm6-h53m-x2xf · GitHub Advisory Database · CC BY 4.0
- CVE-2012-2153 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences