system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute…
Priority MEDIUM 48CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
system/libraries/Email.php in CodeIgniter before 3.1.3 allows remote attackers to execute arbitrary code by leveraging control over the email->from field to insert sendmail command-line arguments.
Why it matters now
EPSS 0.03114 87th percentileScored 2026-11-07
Fix Fixed bcit-ci/codeigniter (Packagist): 3.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | bcit-ci/codeigniter (Packagist) | before 3.1.3 | 3.1.3 | Patch available | GHSA-2pcj-76hj-xqhm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- bcit-ci/codeigniter (Packagist) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-2pcj-76hj-xqhm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* | up to 3.1.2 | Vulnerable | codeigniter4 |
- cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions up to 3.1.2 Vulnerable ·codeigniter4
Remediation
- Fix · GHSA-2pcj-76hj-xqhm bcit-ci/codeigniter (Packagist) Fixed in 3.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10131
- 2026-10-03 Alias added: GHSA-2pcj-76hj-xqhm
References
Patch 2
Advisory 2
More codeigniter4 Codeigniter vulnerabilities
- TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
- TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
- TI-2022-06025 Deserialization of Untrusted Data in Codeigniter4 CVSS 3.1CRITICAL 9.8
- TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
- TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
- TI-2024-19671 CodeIgniter4 Language class DoS Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2016-10131 · CVE Program
- CVE-2016-10131 · NVD
- FIRST EPSS
- GHSA-2pcj-76hj-xqhm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences