The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions.
Priority MEDIUM 46CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-264.
Summary
The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions.
Why it matters now
EPSS 0.01999 80th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* | before 1.2.6 | Vulnerable | benjaminprojas |
- cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* Versions before 1.2.6 Vulnerable ·benjaminprojas
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10886
- 2026-10-03 Alias added: GHSA-hf4m-wpq9-6c3x
References
More benjaminprojas Wp Editor vulnerabilities
- TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
- TI-2022-02259 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
- TI-2024-16819 WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
- TI-2021-06443 WP Editor < 1.2.7 - Authenticated SQL injection CVSS 3.1HIGH 7.2
- TI-2025-02883 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read CVSS 3.1MEDIUM 4.9
Sources
- CVE-2016-10886 · CVE Program
- CVE-2016-10886 · NVD
- FIRST EPSS
- GHSA-hf4m-wpq9-6c3x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences