WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The WP Editor plugin for WordPress is vulnerable to deserialization of untrusted input via the 'current_theme_root' parameter in versions up to, and including 1.2.9. This makes it possible for authenticated attackers with administrative privileges to call files using a PHAR wrapper that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| benjaminprojas | WP Editor | up to 1.2.9 | — | No fix listed | CNA |
- WP Editor Vendorbenjaminprojas Affected up to 1.2.9 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* | before 1.2.9.1 | Vulnerable | benjaminprojas |
- cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* Versions before 1.2.9.1 Vulnerable ·benjaminprojas
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2446
- 2026-10-03 Alias added: GHSA-gm45-ppxv-rfjp
References
More benjaminprojas Wp Editor vulnerabilities
- TI-2016-08924 The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions. CVSS 3.0CRITICAL 9.8
- TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
- TI-2024-16819 WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
- TI-2021-06443 WP Editor < 1.2.7 - Authenticated SQL injection CVSS 3.1HIGH 7.2
- TI-2025-02883 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read CVSS 3.1MEDIUM 4.9
Sources
- CVE-2022-2446 · CVE Program
- CVE-2022-2446 · NVD
- FIRST EPSS
- GHSA-gm45-ppxv-rfjp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences