Read the docs
TI-2021-06443 Aliases CVE-2021-24151GHSA-85ff-hfw5-g96g

WP Editor < 1.2.7 - Authenticated SQL injection

Priority LOW 33CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-89.

Summary

The WP Editor WordPress plugin before 1.2.7 did not sanitise or validate its setting fields leading to an authenticated (admin+) blind SQL injection issue via an arbitrary parameter when making a request to save the settings.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00771 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Editor (Unknown): 1.2.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Editorbefore 1.2.71.2.7Patch availableCNA
  • WP Editor VendorUnknown Affected before 1.2.7 Fixed in 1.2.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:*before 1.2.7Vulnerablebenjaminprojas
  • cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* Versions before 1.2.7 Vulnerable ·benjaminprojas

Remediation

  • Fix · CNA WP Editor (Unknown) Fixed in 1.2.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24151
  2. 2026-10-03 Alias added: GHSA-85ff-hfw5-g96g

References

  • TI-2016-08924 The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions. CVSS 3.0CRITICAL 9.8
  • TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
  • TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
  • TI-2022-02259 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
  • TI-2024-16819 WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
  • TI-2025-02883 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read CVSS 3.1MEDIUM 4.9

Sources