Read the docs
TI-2025-02883 Aliases CVE-2025-3295GHSA-p5jf-h6mx-5w8x

WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read

Priority LOW 23CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.

Summary

The WP Editor plugin for WordPress is vulnerable to arbitrary file read in all versions up to, and including, 1.2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to read arbitrary files on the affected site's server which may reveal sensitive information.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00538 45th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
benjaminprojasWP Editorup to 1.2.9.1—No fix listedCNA
  • WP Editor Vendorbenjaminprojas Affected up to 1.2.9.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:*before 1.2.9.2Vulnerablebenjaminprojas
  • cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* Versions before 1.2.9.2 Vulnerable ·benjaminprojas

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3295
  2. 2026-10-03 Alias added: GHSA-p5jf-h6mx-5w8x

References

  • TI-2016-08924 The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions. CVSS 3.0CRITICAL 9.8
  • TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
  • TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
  • TI-2022-02259 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
  • TI-2024-16819 WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability CVSS 3.1HIGH 7.5
  • TI-2021-06443 WP Editor < 1.2.7 - Authenticated SQL injection CVSS 3.1HIGH 7.2

Sources