WordPress WP Editor plugin <=1.2.7 - Sensitive Data Exposure vulnerability
Priority LOW 33CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Benjamin Rojas WP Editor.This issue affects WP Editor: from n/a through 1.2.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00453 39th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| benjaminprojas | WP Editor | up to 1.2.7 | — | No fix listed | CNA |
- WP Editor Vendorbenjaminprojas Affected up to 1.2.7 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* | before 1.2.8 | Vulnerable | benjaminprojas |
- cpe:2.3:a:benjaminrojas:wp_editor:*:*:*:*:*:wordpress:*:* Versions before 1.2.8 Vulnerable ·benjaminprojas
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-25591
- 2026-10-03 Alias added: GHSA-jcqm-fhp5-5j5j
References
More benjaminprojas Wp Editor vulnerabilities
- TI-2016-08924 The wp-editor plugin before 1.2.6 for WordPress has incorrect permissions. CVSS 3.0CRITICAL 9.8
- TI-2016-08923 The wp-editor plugin before 1.2.6 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2025-02882 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update CVSS 3.1HIGH 7.2
- TI-2022-02259 WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization CVSS 3.1HIGH 7.2
- TI-2021-06443 WP Editor < 1.2.7 - Authenticated SQL injection CVSS 3.1HIGH 7.2
- TI-2025-02883 WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read CVSS 3.1MEDIUM 4.9
Sources
- CVE-2024-25591 · CVE Program
- CVE-2024-25591 · NVD
- FIRST EPSS
- GHSA-jcqm-fhp5-5j5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences