Incorrect authorization in Drupal Core
Priority LOW 37CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
When adding a private file via the editor in Drupal 8.2.x before 8.2.7, the editor will not correctly check access for the file being attached, resulting in an access bypass.
Why it matters now
EPSS 0.01891 79th percentileScored 2026-11-07
Fix Fixed drupal/core (Packagist): 8.2.7drupal/drupal (Packagist): 8.2.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 8.2.x versions before 8.2.7 | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 8.2.0 to before 8.2.7 | 8.2.7 | Patch available | GHSA-w7qx-vwr9-2j3r |
| — | drupal/drupal (Packagist) | 8.2.0 to before 8.2.7 | 8.2.7 | Patch available | GHSA-w7qx-vwr9-2j3r |
- Drupal Core VendorDrupal Affected 8.2.x versions before 8.2.7 Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 8.2.0 to before 8.2.7 Fixed in 8.2.7 Patch available GHSA-w7qx-vwr9-2j3r
- drupal/drupal (Packagist) Vendor— Affected 8.2.0 to before 8.2.7 Fixed in 8.2.7 Patch available GHSA-w7qx-vwr9-2j3r
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:8.2.0:*:*:*:*:*:*:* | 8.2.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.0:beta1:*:*:*:*:*:* | 8.2.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.0:beta2:*:*:*:*:*:* | 8.2.0 beta2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.0:beta3:*:*:*:*:*:* | 8.2.0 beta3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.0:rc1:*:*:*:*:*:* | 8.2.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.0:rc2:*:*:*:*:*:* | 8.2.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.1:*:*:*:*:*:*:* | 8.2.1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.2:*:*:*:*:*:*:* | 8.2.2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.3:*:*:*:*:*:*:* | 8.2.3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:drupal:8.2.4:*:*:*:*:*:*:* | 8.2.4 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:8.2.0:*:*:*:*:*:*:* Versions 8.2.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.0:beta1:*:*:*:*:*:* Versions 8.2.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.0:beta2:*:*:*:*:*:* Versions 8.2.0 beta2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.0:beta3:*:*:*:*:*:* Versions 8.2.0 beta3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.0:rc1:*:*:*:*:*:* Versions 8.2.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.0:rc2:*:*:*:*:*:* Versions 8.2.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.1:*:*:*:*:*:*:* Versions 8.2.1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.2:*:*:*:*:*:*:* Versions 8.2.2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.3:*:*:*:*:*:*:* Versions 8.2.3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:drupal:8.2.4:*:*:*:*:*:*:* Versions 8.2.4 Vulnerable ·Drupal
Remediation
- Fix · GHSA-w7qx-vwr9-2j3r drupal/core (Packagist) Fixed in 8.2.7 Advisory →
- Fix · GHSA-w7qx-vwr9-2j3r drupal/drupal (Packagist) Fixed in 8.2.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6377
- 2026-10-03 Alias added: GHSA-w7qx-vwr9-2j3r
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2017-6377 · CVE Program
- CVE-2017-6377 · NVD
- FIRST EPSS
- GHSA-w7qx-vwr9-2j3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences