Code injection in Drupal Core
Priority MEDIUM 61CWE-19Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.
Why it matters now
EPSS 0.20239 97th percentileScored 2026-11-07
Fix Fixed Drupal Core (Drupal.org): 8.3.4drupal/core (Packagist): 8.3.4+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 8 to before 8.3.4 | 8.3.4 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.0 to before 8.3.4 | 8.3.4 | Patch available | GHSA-9c24-g32g-35rj |
| — | drupal/drupal (Packagist) | 8.0 to before 8.3.4 | 8.3.4 | Patch available | GHSA-9c24-g32g-35rj |
- Drupal Core VendorDrupal Affected 8 to before 8.3.4 Fixed in 8.3.4 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.0 to before 8.3.4 Fixed in 8.3.4 Patch available GHSA-9c24-g32g-35rj
- drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.3.4 Fixed in 8.3.4 Patch available GHSA-9c24-g32g-35rj
Remediation
- Fix · CNA Drupal Core (Drupal.org) Fixed in 8.3.4
- Fix · GHSA-9c24-g32g-35rj drupal/core (Packagist) Fixed in 8.3.4 Advisory →
- Fix · GHSA-9c24-g32g-35rj drupal/drupal (Packagist) Fixed in 8.3.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6920
- 2026-10-03 Alias added: GHSA-9c24-g32g-35rj
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2017-6920 · CVE Program
- CVE-2017-6920 · NVD
- FIRST EPSS
- GHSA-9c24-g32g-35rj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences