Read the docs
TI-2017-04647 Aliases CVE-2017-6921GHSA-h377-287m-w2r9

File REST resource does not properly validate

Priority LOW 30CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

In Drupal 8 prior to 8.3.4; The file REST resource does not properly validate some fields when manipulating files. A site is only affected by this if the site has the RESTful Web Services (rest) module enabled, the file REST resource is enabled and allows PATCH requests, and an attacker can get or register a user account on the site with permissions to upload files and to modify the file resource.

Why it matters now

EPSS 0.01834 79th percentileScored 2026-11-07
Fix Fixed Drupal Core (Drupal): 8.3.4drupal/core (Packagist): 8.3.4+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal CoreDrupal 8 to before 8.3.48.3.4Patch availableCNA
—drupal/core (Packagist)8.0 to before 8.3.48.3.4Patch availableGHSA-h377-287m-w2r9
—drupal/drupal (Packagist)8.0 to before 8.3.48.3.4Patch availableGHSA-h377-287m-w2r9
  • Drupal Core VendorDrupal Affected Drupal 8 to before 8.3.4 Fixed in 8.3.4 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.0 to before 8.3.4 Fixed in 8.3.4 Patch available GHSA-h377-287m-w2r9
  • drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.3.4 Fixed in 8.3.4 Patch available GHSA-h377-287m-w2r9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.0.0 to before 8.3.4VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.3.4 Vulnerable ·Drupal

Remediation

  • Fix · CNA Drupal Core (Drupal) Fixed in 8.3.4
  • Fix · GHSA-h377-287m-w2r9 drupal/core (Packagist) Fixed in 8.3.4 Advisory →
  • Fix · GHSA-h377-287m-w2r9 drupal/drupal (Packagist) Fixed in 8.3.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-6921
  2. 2026-10-03 Alias added: GHSA-h377-287m-w2r9

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources